No uia cmdlets being loaded

Apr 27 at 2:28 PM
After following the documentation for installing the uiautomation.dll i receive error saying other assemblies are not found such as pstestlibrary, ninject, windowsinput, and castle.core.

After executing separate ipmo commands for those and then loading uiautomation the test commands recommended for trouble shooting in the documentation return 0 results.
May 10 at 2:50 PM
Edited May 10 at 2:52 PM
Sorry brfitzge,
I missed your post. My steps on a standard Windows 10 Enterprise x64 v1511 are:
1) navigate to https://uiautomation.codeplex.com/releases/view/125358 and download UIAutomation 0.8.7 Beta 3 .NET35
2) extract the content of the archive downloaded to d:\test_uia_20170510\ . I downloaded the archive via Chrome and there's nothing to unblock. Otherwise, you need to unblock the UIAutomation.dll.
3) then I run PowerShell that's shipped with my Windows OS. It's what PowerShell reports about itself:

$PSVersionTable

Name Value

PSVersion 5.0.10586.672
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0...}
BuildVersion 10.0.10586.672
CLRVersion 4.0.30319.42000
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3
SerializationVersion 1.1.0.1

4) I import the module by issuing the command: ipmo D:\test_uia_20170510\UIAutomation.dll
5) then I run the following command
Get-UiaWindow -Name winpowersh | Get-UiaButton | Read-UiaControlName
The result is
Back by small amount
Back by large amount
Forward by large amount
Forward by small amount
Minimize
Maximize
Close

I'm an administrator on my host and a regular Active Directory domain user in the organization.

Working on lower versions of Windows should be the same. What version of operating system are you using for the module?